BBO Discussion Forums: Difficulty replying to forum posts - BBO Discussion Forums

Jump to content

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

Difficulty replying to forum posts

#21 User is online   smerriman 

  • PipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 3,663
  • Joined: 2014-March-15
  • Gender:Male

Posted 2024-January-17, 19:45

 barmar, on 2024-January-17, 18:40, said:

And I'm sorry to say that forum issues are low on our priority list.

Any chance you accept community solutions on this more than you do for GIB? ;) Give me an hour or two to play with it and I'm sure I'd be able to figure it out.. it's definitely putting off new users from participating in the forum, which can't be good for BBO in general.
0

#22 User is offline   pescetom 

  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 7,095
  • Joined: 2014-February-18
  • Gender:Male
  • Location:Italy

Posted 2024-January-18, 14:01

 barmar, on 2024-January-17, 18:40, said:

We've taken note of this, but it's not clear why this has suddenly become a problem. We haven't made any changes to the forum recently.

And I'm sorry to say that forum issues are low on our priority list.

It didn't suddenly become a problem, it appeared suddenly in December and was and remained an obvious problem.
The forum software cannot have changed (as you repeat regularly, you continue to employ an unsupported legacy) and I doubt it was the fault of forum posters.
0

#23 User is offline   barmar 

  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Group: Admin
  • Posts: 21,375
  • Joined: 2004-August-21
  • Gender:Male

Posted 2024-January-19, 15:01

 pescetom, on 2024-January-18, 14:01, said:

It didn't suddenly become a problem, it appeared suddenly in December and was and remained an obvious problem.

That's what I meant -- we haven't had this problem before, then suddenly it appeared.

#24 User is offline   mycroft 

  • Secretary Bird
  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 7,017
  • Joined: 2003-July-12
  • Gender:Male
  • Location:Calgary, D18; Chapala, D16

Posted 2024-January-26, 11:30

View Postmycroft, on 2024-January-17, 11:12, said:

I have been having repeated and consistent trouble posting my response to "Leading Partner's Bid" thread.

Looking at it, I see that I too fell into smerriman's trap - when I took out the accented word, it posted fine; when I edited to put it back in, that also worked. Thanks for catching that!

And yes, this is new - given where I live half the year, I frequently have written México or Canadá in the past, with no issues. (and I'm editing to add this paragraph, so I expect this to work too).

And yes, copy and paste that offending paragraph into the reply box and I get the dreaded error.

Replying to myself to add:

I edited that evil post (because someone told me it was confusing. Okay, so one sentence of mycroftese became 3 paragraphs of explanation. "Don't let mycroft near the novices", indeed!) I did my usual - first edit, then "use full editor" (and then a couple of rounds in there of "review modified post", but that may not be relevant) - and I got that dreaded "something went wrong" error when I finally decided to submit.

Removed the offending non-ASCII character (á) and it posted.

Put it back with the Edit button (without going to the "use full editor"), and it took just fine.

...and this reply failed until I removed the accented characters in the quote. Added them back using the simple edit box...
When I go to sea, don't fear for me, Fear For The Storm -- Birdie and the Swansong (tSCoSI)
0

#25 User is offline   pescetom 

  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 7,095
  • Joined: 2014-February-18
  • Gender:Male
  • Location:Italy

Posted 2024-January-27, 16:45

At risk of giving an alibi, I have had no such problems in the last few days - maybe something has been fixed but not notified here?
0

#26 User is online   smerriman 

  • PipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 3,663
  • Joined: 2014-March-15
  • Gender:Male

Posted 2024-January-27, 17:07

Can still replicate with exactly the same steps as above. You just can't have posted any funny characters..
0

#27 User is offline   pescetom 

  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 7,095
  • Joined: 2014-February-18
  • Gender:Male
  • Location:Italy

Posted 2024-January-27, 17:11

 smerriman, on 2024-January-27, 17:07, said:

Can still replicate with exactly the same steps as above. You just can't have posted any funny characters..

Probably, thanks.
At most a few suit symbols.
0

#28 User is offline   jillybean 

  • hooked
  • PipPipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 9,481
  • Joined: 2003-November-15
  • Gender:Female
  • Location:Vancouver, Canada
  • Interests:Multi

Posted 2024-January-27, 23:16

View Postpescetom, on 2024-January-27, 16:45, said:

At risk of giving an alibi, I have had no such problems in the last few days - maybe something has been fixed but not notified here?

I'm noticing the same.
0

#29 User is offline   barmar 

  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Group: Admin
  • Posts: 21,375
  • Joined: 2004-August-21
  • Gender:Male

Posted 2024-January-28, 14:16

My guess is that the problem is an incompatibility between the ancient forum software and a recent browser update. I don't think we changed anything in the forum software recently, but browser updates are routine.

#30 User is offline   pescetom 

  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 7,095
  • Joined: 2014-February-18
  • Gender:Male
  • Location:Italy

Posted 2024-January-28, 16:10

View Postsmerriman, on 2024-January-27, 17:07, said:

Can still replicate with exactly the same steps as above. You just can't have posted any funny characters..


You are right that the problem with non-ISO-8859-1 characters persists, but I begin to suspect that there was another parallel problem which has disappeared.
Been a few days now that I have no problems and that was simply impossible for more than a month.
0

#31 User is online   smerriman 

  • PipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 3,663
  • Joined: 2014-March-15
  • Gender:Male

Posted 2024-January-28, 16:30

Perhaps. I had no problems for weeks while others were reporting issues. mikeh seems to have the worst issues, and I regularly see him mistyping accents, likely by holding the key on a mobile down too long, and then of course people replying to him would have issues (and he has been quieter :) ) Seems unlikely two issues popped up at the same time, but there may be other causes.
0

#32 User is online   smerriman 

  • PipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 3,663
  • Joined: 2014-March-15
  • Gender:Male

Posted 2024-January-28, 21:41

View Postbarmar, on 2024-January-28, 14:16, said:

My guess is that the problem is an incompatibility between the ancient forum software and a recent browser update. I don't think we changed anything in the forum software recently, but browser updates are routine.

It's 100% server side, not client side.

While it only started causing internal server errors recently, if you look back at mikeh's old posts, prior to when he had to start posting the word 'test' and then editing, every one with a funny character is now messed up - even ones he (or anyone else) posted a long time ago - e.g.:

https://www.bridgeba...ost__p__1055237

All his curly-apostrophes, which he always uses instead of plain apostrophes, are now showing as ’, as well as other special characters like dashes. They 100% did not appear like this when I originally read the posts, and it's a classic symptom of a server-side character encoding issue. Someone has messed up the database charset.

You can use this to narrow down exactly when this was done - this post at around midday on December 10, EST was his latest one which went through successfully (but then became messed up in the database, as did all the ones prior to that). His next post on December 13 mentioned he had been having problems posting.

So the database was messed up somewhere between those dates - would suggest checking the logs for what was done in that range. If it wasn't an upgrade, it's a very common mistake when transferring old databases from one location to another - perhaps there was a server migration somewhere behind the scenes.

Another example from someone else in 2019.. posts prior to last month are now simply littered with them.
2

#33 User is offline   mycroft 

  • Secretary Bird
  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 7,017
  • Joined: 2003-July-12
  • Gender:Male
  • Location:Calgary, D18; Chapala, D16

Posted 2024-January-29, 09:11

oh my, Microsoft "smart quotes". Who put that into browsers? It was bad enough when programs starting "helping" code, making it totally unusable.

But sure, that would cause these problems too.
When I go to sea, don't fear for me, Fear For The Storm -- Birdie and the Swansong (tSCoSI)
0

#34 User is offline   pescetom 

  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 7,095
  • Joined: 2014-February-18
  • Gender:Male
  • Location:Italy

Posted 2024-January-29, 10:55

11-12 December is when it first became apparent, agreed.

And smerriman is quite right of course, for the first time in weeks we have been replying to threads where mikeh has not yet contributed.
I certainly can't reply to mikeh's latest post in the 'Tricky options' thread (which has a couple of erroneous special characters at the end).
But I can reply to other posts in the thread, which was not (I think) always the case during the last 6 weeks.
0

#35 User is offline   apollo1201 

  • PipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 1,062
  • Joined: 2014-June-01

Posted 2024-February-07, 13:42

Maybe to add on my side

It seems that the apostrophe and the three dots do not work

Otherwise all other characters seem to work so far
0

#36 User is offline   pescetom 

  • PipPipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 7,095
  • Joined: 2014-February-18
  • Gender:Male
  • Location:Italy

Posted 2024-February-07, 15:24

View Postapollo1201, on 2024-February-07, 13:42, said:

It seems that the apostrophe and the three dots do not work


It's possible you are wrong... :)

Or at least the above reply worked first time for me.
0

#37 User is online   smerriman 

  • PipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 3,663
  • Joined: 2014-March-15
  • Gender:Male

Posted 2024-February-07, 15:29

View Postpescetom, on 2024-February-07, 15:24, said:

It's possible you are wrong... :)

Or at least the above reply worked first time for me.

The three dots (ellipsis) character is a separate character from typing a dot three times in row. Some devices like apollo's (and mike's) might convert it automatically.
0

#38 User is offline   barmar 

  • PipPipPipPipPipPipPipPipPipPipPipPip
  • Group: Admin
  • Posts: 21,375
  • Joined: 2004-August-21
  • Gender:Male

Posted 2024-February-07, 18:47

View Postpescetom, on 2024-February-07, 15:24, said:

It's possible you are wrong... :)

Or at least the above reply worked first time for me.

They're talking about Unicode apostrophe and ellipsis characters, not ASCII characters.

#39 User is offline   Gilithin 

  • PipPipPipPipPip
  • Group: Full Members
  • Posts: 967
  • Joined: 2014-November-13
  • Gender:Male

Posted 2024-February-07, 20:52

My recent experience has been that I can reply successfully unless I quote one of Mike's posts, in which case I have to remove the quote before posting, then edit it back in later. I had assumed this was due to the large number of posts Mike has attached to his account but a coding issue might be more logical. Either way, it does not feel like this should be too difficult to track down if someone were to make a decent effort at it.
0

#40 User is online   smerriman 

  • PipPipPipPipPipPipPip
  • Group: Advanced Members
  • Posts: 3,663
  • Joined: 2014-March-15
  • Gender:Male

Posted 2024-February-07, 21:00

View PostGilithin, on 2024-February-07, 20:52, said:

Either way, it does not feel like this should be too difficult to track down if someone were to make a decent effort at it.



:(
0

  • 2 Pages +
  • 1
  • 2
  • You cannot start a new topic
  • You cannot reply to this topic

1 User(s) are reading this topic
0 members, 1 guests, 0 anonymous users